Subject: [Dev] Call graph generator?

From: Tom Bryan <[email-masked]>
Date: Wed, 17 Apr 2002 22:26:02 +0500

Does anyone know of a call graph generator for C code?  Either an independent 
program or an extension for Emacs that does something of the sort.  

Thanks, 
---Tom

---

From: "M. Mueller" <[email-masked]>
Date: Wed, 17 Apr 2002 21:39:46 -0400

On Wednesday 17 April 2002 01:26 pm, you wrote:
> Does anyone know of a call graph generator for C code?  Either an
> independent program or an extension for Emacs that does something of the
> sort.
>
My search for the same thing was not fruitful:
1. C-doc, commercial applicaiton, about $300
2. Doxegen, open source, it looks like you need to integrate it with the code 
to create a document that compiles into a executable; supposedly it will do 
graphs; seems to be a lifestyle choice instead of a quick and dirty graph 
tool; I've not talked to anyone who actually used it

-- 
Michael Mueller
Signalnetware, Inc.
www.signalnetware.com
919.621.6090

---

From: John Beimler <[email-masked]>
Date: 18 Apr 2002 06:36:51 -0400

> tool; I've not talked to anyone who actually used it

Apache group uses it, at least there were plans to on the 2.0 tree. 
Can't find any good links right now, but if you google apache & doxygen
you should be able to find some of it.

Peace.

john
-- 
John Beimler
[email-masked]

---

From: Brent Verner <[email-masked]>
Date: Sun, 21 Apr 2002 08:07:24 -0400

[2002-04-17 22:26] Tom Bryan said:
| Does anyone know of a call graph generator for C code?  Either an independent 
| program or an extension for Emacs that does something of the sort.  

The output of gprof is very informative, but not what I consider
a "graph".  

  b

-- 
"Develop your talent, man, and leave the world something. Records are 
really gifts from people. To think that an artist would love you enough
to share his music with anyone is a beautiful thing."  -- Duane Allman