Subject: [Dev] Performance Profiler

From: "M. Mueller/bhu5nji" <[email-masked]>
Date: Mon, 7 Jan 2002 21:49:15 -0500

Any suggestions on 
a. a Linux performance profiler?
b. how to identify where things are getting gummed up?

I need to figure out why a 21 byte message is taking .9s and more to cross 2 
Linux boxes as follows: 

box1 [ in 10Mb Ether-daemon1-daemon2-daemon3-out 56kb V.35 ]-->
box2 [ in 56kb V.35-daemon3-daemon2-daemon1-out 10Mb ]

It's using Unix protocol datagram socket IPC between the daemons.

box1 is a 700Mhz Duron with 256MB RAM
box2 is a  75Mhz  P5       with 64MB RAM (how much slow down here?)

I'm thinking about:
a. moving to shared memory IPC
b. using pthreads instead of multiple daemons, or going  to monlithic program 
structure
c. identifying unnecessary programs that can be disabled

But before I do any of those ideas I'd like to have a better understanding of 
where the slows downs are actually occuring.

Hmmm.  As I write this I am getting some ideas:
a. Sprinkle in time stamps writes to syslog or some shared memory area
b. Use Ethereal on the "lo" interface

Any help would be appreciated.

Mike

---

From: Jon Carnes <[email-masked]>
Date: Tue, 8 Jan 2002 20:35:29 -0500

> box2 is a  75Mhz  P5       with 64MB RAM (how much slow down here?)

I do the same type of thing with VPN connections, 75Mhz is not nearly fast 
enough especially with three processes manipulating the packets on each end.