[TriLUG] Initramfs

Michael Hrivnak mhrivnak at hrivnak.org
Thu Sep 3 17:34:33 EDT 2009

Is this Debian 5.0, Lenny?

Did you let the installer create all of the LVM stuff?

Are the lvm packages getting installed?

Do you have a non-lvm boot partition?

I've done many of these installs with no trouble.  I always use the text 
installer in expert mode (I don't remember if there even is a graphical 
installer or non-expert mode, but if they exist, I've never used them).


On Tuesday 01 September 2009 10:48:58 pm Brian McCullough wrote:
> Folks,
> I recently installed a machine from scratch ( bare drives, used LVM ),
> but didn't choose "Desktop" or "Web Server" or any of the "pre-defined"
> packages, but just let it install the minimum defaults.
> When I boot the machine, ( and I have tried the installation a couple of
> times ) I get it stalling in the middle of the boot process at an
> "(initramfs)" prompt, where I need to "lvm vgscan" followed by "lvm
> vgchange -a y" before it will successfully complete the boot.
> I have tried the "update-initramfs" command a few times, with various
> parameters, and have even tried playing with the scripts, but the result
> of that was an unbootable machine.
> How and where can I "fix" this, and why didn't the Debian installer get
> it right in the first place?
> Thanks,
> Brian
> --
> TriLUG mailing list        : http://www.trilug.org/mailman/listinfo/trilug
> TriLUG FAQ  : http://www.trilug.org/wiki/Frequently_Asked_Questions

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part.
URL: <http://www.trilug.org/pipermail/trilug/attachments/20090903/60b0a4fb/attachment.pgp>

More information about the TriLUG mailing list